A friendly reminder to update your launcher for Minecraft 1.6

oldSome of our readers have been telling us they cannot update to Minecraft 1.6. We would like to remind our readers that you need to use Mojang's new and improved Minecraft Launcher to play Minecraft 1.6, as well as any future updates and snapshots. The new launcher is completely free and available from here for Windows, Mac OS X, Linux, as well as a simple jar file if you have issues. The new launcher is actually very cool, but I will miss the old launcher a bit. There will always be a place in our hearts for it.

Share this

Previous
Next Post »

3 comments

comments
July 2, 2013 at 9:43 AM delete

I enjoy the new launcher, but each time they updated it for the snapshots in its development, I was required to re-download the launcher so many times!

Reply
avatar
8jaspers
July 2, 2013 at 3:50 PM delete

It will be in our hearts especially if thou here from 1.5 beta or before

Reply
avatar
BubbaZero
July 3, 2013 at 5:51 AM delete

But now it is self-updatable, so that issue is no more! c:

Reply
avatar